HDU-1003 Max Sum

69 篇文章 0 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 
————————————————————尴尬的分割线————————————————————
思路:简单DP。因为是连续的,所以只要和还是非负的,就可以一直加下去。一旦和变成负值,那么将起点和终点置为该点,和也变成该点。然后维护最优解,维护最大的和及其对应的起点终点即可。
代码如下:
/****************************************/
 #include <stdio.h>
/****************************************/
const int IMP = -999999999;

int main() {
	int cas, n;
	scanf("%d", &cas);
	for(int k = 1; k <= cas; k++) {
		int sum = 0, best = IMP, s = 1, e = 1, ans_s, ans_e;
		int a;
		scanf("%d", &n);
		for(int i = 1; i <= n; i++) {
			scanf("%d", &a);
			if(sum >= 0) {
				sum += a;
				e = i;
			} else {
				s = e = i;
				sum = a;
			}
			if(best < sum) {
				best = sum;
				ans_s = s;
				ans_e = e;
			}
		}
		if(k != 1)
			putchar('\n');
		printf("Case %d:\n", k);
		printf("%d %d %d\n", best, ans_s, ans_e);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值