POJ-1386 Play on Words

18 篇文章 0 订阅
10 篇文章 0 订阅
Play on Words
Time Limit: 1000MS Memory Limit: 10000K
   

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.
————————————————————桑心的分割线——————————————————
思路:是欧拉回路还是欧拉通路呢?every word begins with the same letter as the previous word ends.只要求后一个字母的开头和前一个字母的末尾相同,因此是欧拉通路。
判定有向图的欧拉通路:
基图连通、所有顶点的出度、入度相等,或者起点的出度 - 入度 = 1,终点的入度 - 出度 = 1,其余相等。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
/****************************************/
const int M = 1e5+5;
int m, tot, head[26], fa[26];
struct Node {
	int u, v, next;
}edge[M];
bool vis[26];
int od[26], id[26];

void add(int u, int v)
{
	edge[tot].u = u; edge[tot].v = v;
	edge[tot].next = head[u];
	head[u] = tot++;
}

int Find(int x)
{
	if(x != fa[x]) fa[x] = Find(fa[x]);
	return fa[x];
}

void Union(int x, int y)
{
	int fx = Find(x), fy = Find(y);
	if(fx != fy) {
		fa[fy] = fx;
	}
}

bool connect()
{
	for(int i = 0; i < 26; i++) fa[i] = i;
	for(int i = 0; i < m; i++) {//遍历所有边
		int u = edge[i].u, v = edge[i].v;
		Union(u, v);
	}
	int root = -1;
	for(int i = 0; i < 26; i++) if(vis[i]) {
		if(root == -1) root = Find(i);
		else {
			if(Find(i) != root) return false;
		}
	}
	return true;
}

bool Euler()
{
	int one = 0, none = 0;
	for(int i = 0; i < 26; i++) if(vis[i]) {
		if(abs(id[i] - od[i]) >= 2) return false;
		if(od[i] - id[i] == 1) {
			one++;
			if(one > 1) return false;
		}
		if(id[i] - od[i] == 1) {
			none++;
			if(none > 1) return false;
		}
	}
	if(one != none) return false;
	return true;
}

int main()
{
#ifdef J_Sure
//	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	int T;
	scanf("%d", &T);
	while(T--) {
		scanf("%d", &m);
		tot = 0;
		memset(od, 0, sizeof(od));
		memset(id, 0, sizeof(id));
		memset(vis, 0, sizeof(vis));
		memset(head, -1, sizeof(head));
		char s[1005];
		for(int i = 0; i  < m; i++) {
			scanf("%s", s);
			int len = strlen(s);
			int u = s[0] - 'a', v = s[len-1] - 'a';
			od[u]++; id[v]++;
			vis[u] = vis[v] = 1;
			add(u, v);
		}
		bool flag = Euler() && connect();
		if(flag) puts("Ordering is possible.");
		else puts("The door cannot be opened.");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值