【HDU - 2577 How to Type】 DP

H - How to Type


Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8


        
  
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


题意:给出一个字符串,问输出这个字符串需要多少步。


分析:若输入状态为小写(大写),且需要输出的字符为大写(小写)时,需要进行切换,切换有两种方法。第一种,进行一次Caps Lock操作,使得此后的输入状态都变为大写(小写)。第二种:使用Shift + 输入字符的操作(操作计为两步),只会使当前要输入的字符变为大写(小写)状态,此后仍为小写(大写)。

用一个数组dp[i][2]来记录状态,i为当前字符的位置,dp[i][0]和dp[i][1]分别表示Caps Lock的开关状态。


代码如下:

#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define mod 835672545
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int MX = 105;
char str[MX];
int dp[MX][2];
int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%s", str+1);
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 0;
        dp[0][1] = 1;
        int len = strlen(str+1);
        for(int i = 1; i <= len; i++){
            if(isupper(str[i])){
                dp[i][0] = min(dp[i-1][0]+2, dp[i-1][1]+2);
                dp[i][1] = min(dp[i-1][0]+2, dp[i-1][1]+1);
            }
            else{
                dp[i][0] = min(dp[i-1][0]+1, dp[i-1][1]+2);
                dp[i][1] = min(dp[i-1][0]+2, dp[i-1][1]+2);
            }
        }
        printf("%d\n", dp[len][0] < dp[len][1]+1 ? dp[len][0] : dp[len][1]+1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值