HDU 1394 Minimum Inversion Number 树状数组 单点更新

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 


For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 


a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 


You are asked to write a program to find the minimum inversion number out of the above sequences. 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
Output
For each case, output the minimum inversion number on a single line. 
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output

16

题意:每次可以把队首元素放到队尾,求序列的反转逆序对最小有多少对,逆序对:i<j  a[i]>a[j]。


思路:树状数组的单点更新,逆序对求法:逆序列个数是n个,如果a[1]放到a[n]后面,逆序列个数会减少a[1]个,相应会增加N-(a[1]+1)个  ,所以逆序对增加了n-(2*a[1]+1)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 5005;
int c[N];   //前缀和看为一个数组
int a[N],n;
int lowbit(int k)
{
    return k&-k;
}
void update(int i,int x)//更新
{
    while(i<n)
    {
        c[i]+=x;
        i=i+lowbit(i);
    }
}
int getsum(int x)
{
    int re=0;
    while(x>0)
    {
        re+=c[x];
        x-=lowbit(x);
    }
    return re;
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        memset(c,0,sizeof(c));
        int sum=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=n;i>=1;i--)
        {
            update(a[i]+1,1);
            sum+=getsum(a[i]);//从尾部计算小于a[i]的共有多少个,即为第一个序列种的反序对个数 
        }
        int ans=sum;
        for(int i=1;i<=n;i++)
        {
            sum=sum-a[i]+(n-a[i]-1);
            ans=min(ans,sum); //把a[i]+1放到尾部,减去小于a[i]+1的个数,加上大于a[i]+1的个数  
        }
        printf("%d\n",ans);
        
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值