poj 3253 Fence Repair

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25080 Accepted: 8078

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source

一开始使用Huffman的解法却一直在WA,真的不知道为什么,都贴出来吧,不过还是感觉priority_queue比较好用,手残党敲错了一会。。。
AC代码:
/*
Problem: 3253		User: motefly
Memory: 1144K		Time: 172MS
Language: G++		Result: Accepted
*/
#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
int main()
{
    int n;__int64 ans=0;
    while(cin>>n){
    priority_queue<__int64,vector<__int64>,greater<__int64> > q;
    for(int i=0;i<n;i++)
    {
        __int64 x;
        cin>>x;
        q.push(x);
    }
    while(!q.empty())
    {
        __int64 a=q.top();
        q.pop();
        if(q.empty())
            break;
        __int64 b=q.top();
        q.pop();
        ans+=(a+b);
        q.push(a+b);
    }
    cout<<ans<<endl;
    }
    return 0;
}

WA代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=20005;
#define lint __int64
struct node
{
    lint v;
    node *llink,*rlink;
};
node h[maxn];
lint n,ans;
bool cmp(const node&a,const node&b)
{
    return a.v<b.v;
}
int main()
{
    int i,j;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        scanf("%I64d",&h[i].v);
    }
    sort(h,h+n,cmp);
    for(i=1;i<n;i++)
    {
        node t;
        t.llink=&h[i];
        t.rlink=&h[i+1];
        t.v=h[i].v+h[i+1].v;
    for(j=i+1;j<=n;j++)
    if(t.v>h[j].v)
        h[j-1]=h[j];
    else
        break;
    h[j-1]=t;
    ans+=t.v;
    }
    cout<<ans<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值