Dinner

Dinner

时间限制: 100 ms  |  内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示

The tableware only contains: bowl, knife, fork and chopsticks.(根据该提示可以快速写出答案)

题目大意:Little A在比赛中获奖,准备和大家庆祝一番,结果发现自己的餐具不够,于是他去寻找餐具,我们的任务是从给出的物品中选出餐具(就是从给出的英文单词中选出要求的,提示中的四个bowl, knife, fork and chopsticks),读懂意思后,答案基本就出来了!

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	char ch[15];//支持最长的字符串为15
	while(scanf("%d",&n)!=EOF){
		while(n--)
		{
			scanf("%s",ch);
			if(strcmp(ch,"bowl")==0)printf("%s ",ch);
			else if(strcmp(ch,"knife")==0)printf("%s ",ch);
			else if(strcmp(ch,"fork")==0)printf("%s ",ch);
			else if(strcmp(ch,"chopsticks")==0)printf("%s ",ch);
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值