HDU 电梯题:(Problem ID:1008)

HDU 题址:http://acm.hdu.edu.cn/showproblem.php?pid=1008


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41


思路:乘电梯时,每上一层楼要花6秒时间,停一层要花5秒,每下一层楼要花4秒。

         当now<=next时,说明在上楼,共花(next-now)*6+5时间,与sum累加可得当前共花的时间。

    当now>next时,说明在下楼,共花(now-next)*4+5;时间,与sum累加可得当前共花的时间。

  (注:输入的n数据表示之后共有几层楼层变动,每行都是默认从0层开始上楼的......微笑


AC代码:

#include<stdio.h>

 

int main()

{

         intn,sum=0;

         intnow=0,next;

         scanf("%d",&n);

         while(n)

         {

                   scanf("%d",&next);

                   if(now<=next)

                            sum+=(next-now)*6+5;

                   elseif(now>next)

                            sum+=(now-next)*4+5;

                   now=next;

                   n--;

                   if(n==0)

                   {

                            printf("%d\n",sum);

                            scanf("%d",&n);sum=0;now=0;continue;

                   }

         }

 

         return0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值