简单数学归纳题:
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)ifno exists that a,then print "no".
Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
11
100
9999
Sample Output
22
no
43
AC代码:
#include<stdio.h>
#include<math.h>
int main()
{
int a,k;
while(scanf("%d",&k)!=EOF)
{
for(a=0;a<10000;a++)
{
if((18+k*a)%65==0)
{
printf("%d\n",a);break;
}
}
if(a>=10000)
printf("no\n");
}
return 0;
}