hdu5532Almost Sorted Array

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 850    Accepted Submission(s): 297


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source
 

#include<bits/stdc++.h>
const int maxn=110000;
int n,a[maxn];
bool b[maxn];
bool c[maxn];
void doit(){
    scanf("%d",&n);b[1]=c[1]=1;
    for(int i=1;i<=n;i++){
        scanf("%d",a+i);
        if(i>1&&a[i]>=a[i-1]&&b[i-1])b[i]=1;else if(i>1) b[i]=0;
        if(i>1&&a[i]<=a[i-1]&&c[i-1])c[i]=1;else if(i>1)c[i]=0;
    }
  //  for(int i=1;i<=n;i++)printf("b[%d]=%d c[%d]=%d\n",i,b[i],i,c[i]);
    if(n<=3||b[n]||c[n]||b[n-1]||c[n-1]){puts("YES");return;}
    b[0]=c[0]=b[n]=c[n]=1;
    for(int i=n-1;i;i--){
        if(i>1&&b[i+1]&&b[i-1]&&a[i-1]<=a[i+1]){puts("YES");return;}
        if(i>1&&c[i+1]&&c[i-1]&&a[i-1]>=a[i+1]){puts("YES");return;}
        if(a[i+1]>=a[i]&&b[i+1])b[i]=1;else b[i]=0;
        if(a[i+1]<=a[i]&&c[i+1])c[i]=1;else c[i]=0;
    }
    if(b[2]||c[2]){puts("YES");return;}
    puts("NO");
}
int main(){
    int t;scanf("%d",&t);
    for(int i=1;i<=t;i++)doit();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值