POJ 14 Labeling Balls

Labeling Balls

Time Limit:1000MS  Memory Limit:65536K
Total Submit:12 Accepted:5

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

1、No two balls share the same label.
2、The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

 

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4 


 
 
题目大意:
     这道题每次输入a,b的时候表示的是编号为a的球比编号为b的球轻,最后输出的是从编号 1
    到编号 n每个小球的重量,如果存在多组解,输出使最小重量尽量排在前边的那组解,亦即 所有解中 1到 n号球的重量的字典序最小
本题目为拓扑排序,如果形成环,也就是-1,那么必然没有出度为0的,如果有出度为0的,那把最大的重量给它,把和它关联的边去掉,然后那些节点度数--,每次选序号最大的而且出度为0的,给它赋值重量

#include<cstdio>
#include<queue>
#include<iostream>
#define N 205
using namespace std;

bool map[N][N];
int out_degree[N];
void toposort(int n)
{
    /*找出出度为0且编号最大的球*/
    priority_queue<int>q;
    int w[N],cnt=n,i;
    for(i=1; i<=n; i++)
        if(out_degree[i]==0)
            q.push(i);
    while(!q.empty())
    {
        int ele=q.top();
        q.pop();
        w[ele]=cnt--;//给球赋重量
        for(i=1; i<=n; i++)
            if(map[i][ele])
            {
                out_degree[i]--;
                if(out_degree[i]==0)
                    q.push(i);
            }
    }
    if(cnt)
        printf("-1\n");
    else
        for(i=1; i<=n; i++)
            printf("%d%c",w[i],i!=n?' ':'\n');
}
int main()
{
    int t,n,m,a,b,i,j;
    for(scanf("%d",&t); t--;)
    {
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; i++)
        {
            out_degree[i]=0;
            for(j=1; j<=n; j++)
                map[i][j]=false;
        }
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(!map[a][b])map[a][b]=true,out_degree[a]++;
        }
        toposort(n);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值