UVA 624 CD(01背包输出)

Description

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.


Assumptions:

  • number of tracks on the CD. does not exceed 20
  • no track is longer than N minutes
  • tracks do not repeat
  • length of each track is expressed as an integer number
  • N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input 

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output 

Set of tracks (and durations) which are the correct solutions and string `` sum:" and sum of duration times.

Sample Input 

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

Sample Output 

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45



Miguel A. Revilla
2000-01-10

解题报告:题目大意就是讲要将cd里面歌转存到磁带上,每首歌都有固定的时间。而磁带的存的总时间限制是固定的,问最多能存多长时间的歌,按照磁带中的顺序来输出具体存的歌。这题的处理也是01背包,不同的是需要输出具体的。有一点就是v=w,所以可以直接用可达来才处理。然后用递归输出路径。

dp[i]表示存取时间为i的最后一首歌的时间。代码如下:

#include <cstdio>
#include <cstring>
int t[22], dp[10005], vol, n, i, j, ans;
//dp[i]为达到i的前一个时间的值。
void print(int x) {
    if(x <= 0) return ;
    print(x - dp[x]);
    printf("%d ", dp[x]);
}
int main() {
    while (scanf("%d%d", &vol, &n) != EOF) {
        memset(dp, -1, sizeof(dp)), dp[0] = 0;
        ans = 0;
        for (i = 0; i < n; i ++) {
            scanf("%d", t + i);
            for (j = vol; j >= t[i]; j --) {
                if(dp[j-t[i]] != -1 && dp[j] == -1) {
                    dp[j] = t[i];
                    if (j > ans) ans = j;
                }
            }
        }
        print(ans);
        printf("sum:%d\n", ans);
    }
    return 0;
}

网上也有一些没有按照要求输出路劲的,但是也可以ac,用vis数组来标记路径。

#include <cstdio>
#include <cstring>
int track[22], dp[10005], vis[21][10005], vol, n, i, j;

int main() {
    while (scanf("%d%d", &vol, &n) != EOF) {
        memset(dp, 0, sizeof(dp));
        memset(vis, 0, sizeof(vis));
        for (i = 0; i < n; i ++) {
            scanf("%d", track + i);
            for (j = vol; j >= track[i]; j --) {
                if(dp[j-track[i]] + track[i] > dp[j]) {
                    dp[j] = dp[j-track[i]] + track[i];
                    vis[i][j] = 1;
                }
            }
        }
        for (int i = n, j = vol; i >= 0; i --) {
            if(vis[i][j]) {
                printf("%d ", track[i]);
                j -= track[i];
            }
        }
        printf("sum:%d\n", dp[vol]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值