HDOJ 5143 NPY and arithmetic progression DFS


DFS.....

多余3个的数可以自己成等比数列

和其他数组合成等比数列的有1,2,3,  2,3,4  1,2,3,4 三种情况

NPY and arithmetic progression

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 189    Accepted Submission(s): 61


Problem Description
NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers,  a1,a2,a3,a4 , which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
 

Input
The first line contains a integer T — the number of test cases ( 1T100000 ).
The next T lines,each contains 4 integers  a1,a2,a3,a4(0a1,a2,a3,a4109) .
 

Output
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
 

Sample Input
  
  
3 1 2 2 1 1 0 0 0 3 0 0 0
 

Sample Output
  
  
Yes No Yes
Hint
In the first case,the numbers can be divided into {1,2,3} and {2,3,4}. In the second case,the numbers can't be divided properly. In the third case,the numbers can be divided into {1,1,1}.
 

Source
 


/* ***********************************************
Author        :CKboss
Created Time  :2014年12月13日 星期六 23时09分55秒
File Name     :B_2.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <cmath>

using namespace std;

bool flag;

bool ck(int a,int b,int c,int d)
{
	/// check
	if(a==0&&b==0&&c==0&&d==0) return true;
	if( ((a!=0&&a>=3)||(a==0)) && ((b!=0&&b>=3)||(b==0)) && ((c!=0&&c>=3)||(c==0)) && ((d!=0&&d>=3)||(d==0)) ) return true;

	if(a-1>=0&&b-1>=0&&c-1>=0&&d-1>=0)
		if(ck(a-1,b-1,c-1,d-1)) return true;

	if(a-1>=0&&b-1>=0&&c-1>=0)
		if(ck(a-1,b-1,c-1,d)) return true;

	if(b-1>=0&&c-1>=0&&d-1>=0)
		if(ck(a,b-1,c-1,d-1)) return true;

	return false;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		int a,b,c,d;
		scanf("%d%d%d%d",&a,&b,&c,&d);
		if(ck(a,b,c,d)==true) puts("Yes");
		else puts("No");
	}
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值