nyoj269VF(dp)



VF

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the  N th VF in the point  S is an amount of integers from 1 to  N that have the sum of digits  S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with  N = 10 9) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
//题意:1~1000000000之间,各位数字之和等于给定s的数的个数,每行给出一个数s(1 ≤ s ≤ 81),求出1~10^9内各位数之和与s相等的数的个数。
//所有情况都求出来。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[15][90];//dp[i][j]是前i位数的和为j的数有几个。
int k;
int main()
{
    memset(dp,0,sizeof(dp));
    for(int i=1; i<=9; i++)
    {
        dp[1][i]=1;
    }
    for(int i=2; i<=9; i++)
    {
        for(int j=1; j<=9*i; j++)
        {
            for(int l=0; l<=9&&l<=j; l++)
            {
                dp[i][j]+=dp[i-1][j-l];
            }
        }
    }
    while(~scanf("%d",&k))
    {
        int sum=0;
        if(k==1)
            printf("10\n");
        else
        {
            for(int i=1; i<=9; i++)
            {
                sum+=dp[i][k];
            }
            printf("%d\n",sum);
        }
    }
}

转载于:https://www.cnblogs.com/da-mei/p/9053344.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值