HDU1250 Hat's Fibonacci 【亿进制】

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7854    Accepted Submission(s): 2551


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

#include <stdio.h>
#include <string.h>

#define mod 1000000000

int arr[10001][230];

void Add(int i, int j) {
	for(int k = 0; k < 230; ++k) {
		arr[i][k] += arr[j][k];
		if(arr[i][k] >= mod) {
			arr[i][k] -= mod;
			++arr[i][k+1];
		}
	}
}

int main() {
	int i, j, n;
	for(i = 1; i < 5; ++i)
		arr[i][0] = 1;
	for(i = 5; i < 10001; ++i) {
		for(j = i - 4; j < i; ++j)
			Add(i, j);
	}
	while(scanf("%d", &n) == 1) {
		for(j = 229; ; --j)
			if(arr[n][j]) {
				printf("%d", arr[n][j]);
				break;
			}
		for(--j; j >= 0; --j)
			printf("%09d", arr[n][j]);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值