1135: Max Sum

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines.

The first line is "Case #:", # means the number of the test case.

The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.

If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


#include <iostream>
using namespace std;
int get(int data[] , int &l , int &r , int dl)
{
     int max = -10000000 ;
     l=0;r=0;
     int t=1;
     int mt=0;
     for(int i=0 ; i < dl ; i++)
     {  mt = mt +data[i];
        if(mt > max)
        {
            max =  mt;
            l = t ; r = i+1 ;
        }
        if(mt < 0)
        {
            mt = 0 ;
            t = i+2 ;
        }
     }
     return max ;
}
int main()
{
    int num ;
    cin >> num ;
    for(int k = 1 ; k <= num ;k++)
    {
        int lg = 0 ;
        cin >>lg ;
        int *data = new int[lg];
        for(int i =0 ;i < lg ; i++)
            cin >>data[i];
        int l=0,r=lg-1 ;
        int max=0;
        max = get(data,l,r,lg);
        cout<<"Case "<<k<<":"<<endl;
        cout<<max<<" "<<l<<" "<<r<<endl;
        if(k!=num)  cout<<endl;
    }
    return 0 ;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值