[二分]poj3104 Drying

C - Drying
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
3
2 3 9
5
3
2 3 6
5
Sample Output
3
2

n件衣服要烘干,第i件衣服的水分为a[i],烘干机每次只能放进一件衣服,每分钟能烘干的水分为k,放在外面的衣服每分钟水分-1,求最短需要多少时间把衣服全部烘干。

这题也是二分,不同之处在于有一个预先处理的过程,可以把check写成一个固定的表达式:经过k分钟后,第i件衣服是否还需要继续烘干,如果还需要继续烘干,就丢到烘干机里面花若干时间把他烘干,最后计算需要烘干的总时间是否超过给定的时间即可。

做的时候发现有问题,一直在wa……有一个让我很郁闷的地方:在写二分的时候,先记录下当前位置的解,然后继续二分,否则就有可能漏掉最优解。具体看代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+100;
int n,k,a[maxn];
bool check(long long val)
{
    long long cnt=0;
    for(int i=0;i<n;i++)
    {
        if(a[i]-val<=0)
            continue;
        if(k==1)
            return false;
        cnt+=(a[i]-val+k-2)/(k-1);
        if(cnt>val)
            return false;
    }
    return true;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        long long l=0,r=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            r+=a[i];
        }
        scanf("%d",&k);
        long long ans=0;
        while(l<=r)
        {
            long long mid=(l+r)>>1;
            if(check(mid))
            {
                ans=mid;
                r=mid-1;
            }
            else
                l=mid+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值