hdu 3706 Second My Problem First

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1223    Accepted Submission(s): 468


Problem Description
Give you three integers n, A and B. 
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B.
 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1). 
Process to end of file.
 

Output
For each case, output the answer in a single line.
 

Sample Input
  
  
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

Sample Output
  
  
2 3 4 5 6
 

这道题目一看就知道是单调队列了,恒定的区间长度维护一个最小值,这个是单调队列最明显的性质了。

代码:

#include<cstdio>
#include<iostream>
#define Maxn 10000010
#define ll long long
using namespace std;

int p[Maxn],sq[Maxn<<1];
int main()
{
    int n,a,b;
    while(~scanf("%d%d%d",&n,&a,&b)){
        p[0]=1;
        for(int i=1;i<=n;i++)
            p[i]=p[i-1]*(ll)a%b;
        int s=0,e=-1;
        int res=1;
        for(int i=1;i<=n;i++){
            while(s<=e&&p[sq[e]]>=p[i]) e--;
            sq[++e]=i;
            if(sq[s]+a-1<sq[e]) s++;
            res=(ll)res*p[sq[s]]%b;
        }
        printf("%d\n",res);
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值