hdu3706 Second My Problem First

Problem Description
Give you three integers n, A and B. 
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B.
 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1). 
Process to end of file.
 

Output
For each case, output the answer in a single line.
 

Sample Input
  
  
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

Sample Output
  
  
2 3 4 5 6

这题可以用单调队列做,存储每次的时间和大小。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
#define maxn 10000005
#define ll __int64
ll q[maxn][2];
int main()
{
    ll n,m,A,B,ans,front,rear,time,sum,timenow;
    int i,j;
    while(scanf("%I64d%I64d%I64d",&n,&A,&B)!=EOF)
    {
        front=1;rear=0;ans=1;sum=1;
        for(i=1;i<=n;i++){
            ans=(ans*A)%B;
            if(i-A<1)time=1;
            else time=i-A;
            while(front<=rear && ans<=q[rear][0]){
                rear--;
            }
            rear++;
            q[rear][0]=ans;q[rear][1]=i;
            while(front<=rear && q[front][1]<time)front++;
            sum=(sum*q[front][0])%B;
        }
        printf("%I64d\n",sum%B);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值