ZOJ Problem Set - 2913

Bus Pass

Time Limit: 5 Seconds       Memory Limit: 32768 KB

You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:


Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!

Input

On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers idi (1 <= idi <= 9 999) and mzi (1 <= mzi <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mzi integers: the numbers of the adjacent zones.

nr lines starting with one integer mri (1 <= mri <= 20), indicating the number of zones the ith bus trip visits, followed by mri integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

Output

For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

Sample Input

1
17 2
7400 6 7401 7402 7403 7404 7405 7406
7401 6 7412 7402 7400 7406 7410 7411
7402 5 7412 7403 7400 7401 7411
7403 6 7413 7414 7404 7400 7402 7412
7404 5 7403 7414 7415 7405 7400
7405 6 7404 7415 7407 7408 7406 7400
7406 7 7400 7405 7407 7408 7409 7410 7401
7407 4 7408 7406 7405 7415
7408 4 7409 7406 7405 7407
7409 3 7410 7406 7408
7410 4 7411 7401 7406 7409
7411 5 7416 7412 7402 7401 7410
7412 6 7416 7411 7401 7402 7403 7413
7413 3 7412 7403 7414
7414 3 7413 7403 7404
7415 3 7404 7405 7407
7416 2 7411 7412
5 7409 7408 7407 7405 7415
6 7415 7404 7414 7413 7412 7416

Sample Output

4 7400


这道题是多次BFS,以每条路径上的点为起点,来一遍bfs,得到该点到地图上所有点的最短距离,更新一遍数组,数组的值是不停地被刷大的,取大就可以保证地图上的某点 到这些路径上的所有点都可以在这个距离内到达。
最后来一遍取小,最大里面找到一个点,距离到这些线路最短,并且更新中心坐标。

写了两份代码.
STL版:
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
#define Maxn 10010
using namespace std;

vector<int> Map[Maxn];
queue<int> que[2];
int reach[Maxn]; //单个点访问次数记录
int ans[Maxn]; //记录某个区域到线路所有区域最大距离
int cur; //cur为当前已访问区域数量
void BFS(int zone)
{
    int a=0,b=1,val=1; //val表示距离
    if(reach[zone]<cur){ //未访问
        reach[zone]=cur;
        que[a].push(zone);
        ans[zone]=max(ans[zone],val); //更新最大值
    }
    while(!que[a].empty()) {
        swap(a,b);
        val++; //深一层
        while(!que[b].empty()){
            int att=que[b].front();
            que[b].pop();
            for(vector<int>::iterator it=Map[att].begin();it!=Map[att].end();it++){
                if(reach[*it]<cur){ //未访问
                    reach[*it]=cur;
                    que[a].push(*it);
                    ans[*it]=max(ans[*it],val); //更新最大值
                }
            }
        }
    }
}
int main()
{
    int t;
    int nz,nr,mr; //nz为区域数,nr为路线数,mr为每条线路的区域数
    int id,mz,zone; //id为区号,mz为相邻区域数
    int MIN,index; //MIN为最小距离,index为最小区域号
    cin>>t;
    while(t--){
        cur=0;
        memset(reach,-1,sizeof(reach));
        memset(ans,0,sizeof(ans));
        scanf("%d%d",&nz,&nr);
        for(int i=0;i<nz;i++){ //构造邻接表
            scanf("%d%d",&id,&mz);
            Map[id].clear();
            for(int j=0;j<mz;j++){
                scanf("%d",&zone);
                Map[id].push_back(zone);
            }
        }
        for(int i=0;i<nr;i++){
            scanf("%d",&mr);
            for(int j=0;j<mr;j++){
                scanf("%d",&zone);
                BFS(zone);
                cur++;
            }
        }
        int MIN=0x3f3f3f3f;
        for(int i=0;i<Maxn;i++)
            if(reach[i]==cur-1&&ans[i]<MIN){
                MIN=ans[i];
                index=i;
            }
        printf("%d %d\n",MIN,index);
    }
    return 0;
}

非STL版:
#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 10010
using namespace std;

int head[Maxn],next[Maxn*50];
int cnt[Maxn],ct[Maxn],q[2][Maxn],a[Maxn*10];
void bfs(int x,int cou){
    int pa=0,pb=1,step=0;
    int s1=0,e1=-1,s2,e2;
    q[pa][++e1]=x;
    ct[x]=cou;
    while(s1<=e1){
        step++;
        s2=s1,e2=e1;
        s1=0,e1=-1;
        pa^=1,pb^=1;
        while(s2<=e2){
            int t=q[pb][s2++];
            cnt[t]=step>cnt[t]?step:cnt[t];
            for(int i=head[t];i!=-1;i=next[i])
                if(ct[a[i]]!=cou){
                    q[pa][++e1]=a[i];
                    ct[a[i]]=cou;
                }
        }
    }
}
int main()
{
    int t,n,m,b,k,id;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(head,-1,sizeof head);
        memset(cnt,0,sizeof cnt);
        memset(ct,0,sizeof ct);
        int tot=-1;
        for(int i=0;i<n;i++){
            scanf("%d%d",&id,&k);
            while(k--){
                scanf("%d",&a[++tot]);
                next[tot]=head[id];
                head[id]=tot;
            }
        }
        int cou=0;
        for(int i=0;i<m;i++){
            scanf("%d",&k);
            while(k--){
                scanf("%d",&b);
                bfs(b,++cou);
            }
        }
        int ans=1<<30;
        for(int i=1;i<=9999;i++)
            if(cnt[i]&&cnt[i]<ans){
                ans=cnt[i];
                id=i;
            }
        printf("%d %d\n",ans,id);
    }
	return 0;
}

依赖STL总不是一件好事,但自己写有个麻烦,next和a数组要开大,具体多大,取决于题目规模,可能会RE。
因为每输入一条边就是创建一个 next的,在不知道题目告诉边数的上限情况下,只能尽量开大了。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值