LA3263 平面图的欧拉公式

Little Joey invented a scrabble machine that he called Euler, after the great mathematician. In his primary school Joey heard about the nice story of how Euler started the study about graphs. The problem in that story was - let me remind you - to draw a graph on a paper without lifting your pen, and finally return to the original position. Euler proved that you could do this if and only if the (planar) graph you created has the following two properties: (1) The graph is connected; and (2) Every vertex in the graph has even degree.


Joey's Euler machine works exactly like this. The device consists of a pencil touching the paper, and a control center issuing a sequence of instructions. The paper can be viewed as the infinite two-dimensional plane; that means you do not need to worry about if the pencil will ever go off the boundary.

In the beginning, the Euler machine will issue an instruction of the form (X0, Y0) which moves the pencil to some starting position (X0, Y0). Each subsequent instruction is also of the form (X',Y'), which means to move the pencil from the previous position to the new position (X'Y'), thus draw a line segment on the paper. You can be sure that the new position is different from the previous position for each instruction. At last, the Euler machine will always issue an instruction that move the pencil back to the starting position (X0, Y0). In addition, the Euler machine will definitely not draw any lines that overlay other lines already drawn. However, the lines may intersect.

After all the instructions are issued, there will be a nice picture on Joey's paper. You see, since the pencil is never lifted from the paper, the picture can be viewed as an Euler circuit.

Your job is to count how many pieces (connected areas) are created on the paper by those lines drawn by Euler.

Input 

There are no more than 25 test cases. Ease case starts with a line containing an integer N$ \ge$4, which is the number of instructions in the test case. The following N pairs of integers give the instructions and appear on a single line separated by single spaces. The first pair is the first instruction that gives the coordinates of the starting position. You may assume there are no more than 300 instructions in each test case, and all the integer coordinates are in the range (-300, 300). The input is terminated when N is 0.

Output 

For each test case there will be one output line in the format


Case x: There are w pieces.,


where x is the serial number starting from 1.


Note: The figures below illustrate the two sample input cases.

\epsfbox{p3263.eps}

Sample Input 

5
0 0 0 1 1 1 1 0 0 0 
7 
1 1 1 5 2 1 2 5 5 1 3 5 1 1 
0

Sample Output 

Case 1: There are 2 pieces. 
Case 2: There are 5 pieces.

暴力规范相交的点,这些点是新生成的点,找出所有点后要去重,这样顶点个数就知道了。

然后暴力每个点,看是否在某条线段上(不包括端点),如果在,表示该点将线段截断,也就是增加一条线段,最后知道了所有线段数目,用欧拉公式计算面数r=m+2-n

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define eps 1e-8
#define type double
#define Maxn 310
using namespace std;

int sgn(double x){
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    return 1;
}
struct vec{ //向量
    type x,y;
    vec(type xx=0,type yy=0):x(xx),y(yy){}
    bool operator==(vec a){
        return !sgn(x-a.x)&&!sgn(y-a.y);
    }
    vec operator*(type k){
        return vec(k*x,k*y);
    }
};
struct point{ //点
    type x,y;
    point(type xx=0,type yy=0):x(xx),y(yy){}
    vec operator-(point a){
        return vec(x-a.x,y-a.y);
    }
    point operator+(vec a){
        return point(x+a.x,y+a.y);
    }
    bool operator==(point a){
        return !sgn(x-a.x)&&!sgn(y-a.y);
    }
    bool operator<(const point &a)const{
        return x<a.x||x==a.x&&y<a.y;
    }
}p[Maxn],v[Maxn*Maxn];
type dotp(vec a,vec b){ //点积a·b
    return a.x*b.x+a.y*b.y;
}

type crossp(vec a,vec b){ //叉积a×b
    return a.x*b.y-b.x*a.y;
}
bool seg_ins(point a,point b,point c,point d){
    return sgn(crossp(a-c,d-c)*crossp(b-c,d-c))<0
         &&sgn(crossp(c-a,b-a)*crossp(d-a,b-a))<0;
}
point line_ins(point a,point b,point c,point d){
    vec u=a-c,v=b-a,w=d-c;
    double t=crossp(w,u)/crossp(v,w);
    return a+v*t;
}
bool onseg(point a,point b,point c){
    return !sgn(crossp(b-a,c-a))&&sgn(dotp(a-c,b-c))<0;
}
int main()
{
    int n,cas=1;
    while(cin>>n,n){
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            v[i]=p[i];
        }
        n--;
        int tot=n;
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
                if(seg_ins(p[i],p[i+1],p[j],p[j+1])) //规范相交
                    v[tot++]=line_ins(p[i],p[i+1],p[j],p[j+1]);
        sort(v,v+tot);
        tot=unique(v,v+tot)-v;
        int e=n;
        for(int i=0;i<tot;i++)
            for(int j=0;j<n;j++)
                if(onseg(p[j],p[j+1],v[i])) e++;
        printf("Case %d: There are %d pieces.\n",cas++,e+2-tot);
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值