Bicoloring uva DFS

Bicoloring 

In 1976 the ``Four Color Map Theorem" was proven with the assistance of acomputer. This theorem states that every map can be colored using only fourcolors, in such a way that no region is colored using the same color as aneighbor region.

Here you are asked to solve a simpler similar problem. Youhave to decide whether a given arbitrary connected graph can be bicolored.That is, if one can assign colors (from a palette of two) to the nodes in sucha way that no two adjacent nodes have the same color. To simplify the problemyou can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connectedto a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at leastone path from any node to any other node.

Input 

The input consists of several test cases. Each test casestarts with a line containing the number n (1 < n < 200) of differentnodes. The second line contains the number of edges l. After this, l lineswill follow, each containing two numbers that specify an edge between the twonodes that they represent. A node in the graph will be labeled using a number a ( $0 \le a < n$).

An input with n = 0 will mark the end of the input and isnot to be processed.

Output 

You have to decide whether the input graph can bebicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output 

NOT BICOLORABLE.
BICOLORABLE.

解决方案:受前面的影响,还以为是四种颜色,没想到是两种,审题啊!

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int Map[220][220];
int color[220];
bool vis[220];
int n;
bool flag;
void dfs(int s)
{
    vis[s]=true;
    for(int i=0;i<n;i++)
    {
        if(Map[s][i]){
            if(!vis[i])
            {
                vis[i]=true;
                color[i]=!color[s];
                dfs(i);
            }
            else if(color[i]==color[s])//由于只有两种颜色,dfs,当出现两相邻的相同时,就"NOT BICOLORABLE.“

            {
               flag=false;
               return ;
            }
        }

    }

}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        int m;
        scanf("%d",&m);
        memset(Map,0,sizeof(Map));
        memset(vis,false,sizeof(vis));
        memset(color,0,sizeof(color));
        for(int i=0;i<m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            Map[a][b]=Map[b][a]=1;
        }
        flag=true;
        dfs(0);
        if(flag)
        {
            cout<<"BICOLORABLE.\n";
        }
        else{
            cout<<"NOT BICOLORABLE.\n";
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值