欧几里德和扩展(hdu 1222)

欧几里德:求两个数的最大公约数。gcd(a,b) = gcd(b,a mod b)

代码:

int gcd(int x,int y){
	return x%y==0?y:gcd(y,x%y);

}
扩展欧几里德:对于不完全为 0 的非负整数 a,b,gcd(a,b)表示 a,b 的最大公约数,必然存在整数对 x,y ,使得 gcd(a,b)=ax+by。

用途:1.求不定方程:ax+by=c.    2.求解模线性方程 ( 线性同余方程 )    3.求解模的逆元。
基本方法:递归

思路:c %(a,b)=0,则该方程有解。 由 gcd(a,b)=gcd(b,a%b),

   则gcd = ax1+by1 = bx2+(a%b)y2 = bx2+(a-(a/b)*b)*y2 = ay2+b(x-a/b*y2).

等式求解为 x1 = y2 ,  y1 = x2-a/b*y2 . 递归结束条件为b==0,此时x=1.

代码:

int exgcd(int a,int b,int &x,int &y){
	if (b==0){
		x=1;y=0;
		return a;
	}
	int ans = exgcd(b,a%b,x,y);
	int temp = x;
	x = y;
	y = temp-a/b*y;
	return ans;	
}//x,y为一组特解x0,y0.   x = x0+(b/gcd)*i,y = y-(a/gcd)*i.
求解不定方程,代码:

bool jie(int a,int b,int c,int &x,int &y){
	int d = exgcd(a,b,x,y);
	if (c%d!=0) return false;
	int k=c/d;
	x*=k;
	y*=k;
	return true;
}

简单例题:hdu 1222

原题

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7377    Accepted Submission(s): 3700


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
  
  
2 1 2 2 2
 

Sample Output
  
  
NO YES
题意:狼从0开始,每隔m个洞进洞 ,共n个洞,问有没有安全洞,即狼不会进的洞。

题解:找规律,若m,n的最大公约数大于1(即m,n不互质),就有安全洞。

代码:
#include<cstdio>
using namespace std;

int gcd(int a,int b){
	if (a%b == 0)
	return b;
	return gcd(b,a%b);
}
int main(){
	int t,n,m;
	scanf("%d",&t);
	while (t--){
		scanf("%d %d",&m,&n);
		if (gcd(m,n)>1)
		printf ("YES\n");
		else
		printf ("NO\n");
	}
	return 0;
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值