Light OJ 1078:Integer Divisibility

同余定理(明天贴原图链接)

1078 - Integer Divisibility
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

题意:找出能整除n 的只含d 的数字的位数。

题解:同余定理,否则会超时,比赛时把题想的复杂了,竟然用了快速幂+同余

代码:(还没提交,这个点,vj和poj都提交失败了,可能是宿舍网太渣)

<span style="font-size:18px;">#include<cstdio> 
using namespace std;
int main(){
int t,n,d,i;
int cas;
scanf ("%d",&t);
cas = 1;
while (t--){
scanf ("%d %d",&n,&d);
int s=d%n;
i=1;
//放错位置了,cas=1;
while (s){
s=s*10+d;
s%=n;
i++;
}
printf ("Case %d: %d\n",cas++,i);
}
return 0;
}</span>
AC。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值