(hdu step 5.1.2)Is It A Tree?(判断是不是一棵树)

题目:

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 850 Accepted Submission(s): 273
 
Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
 
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 
Output

            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
 
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
 
 
Source
North Central North America 1997
 
Recommend
Ignatius.L

题目大意:

               给出一堆边给你,让你判断这是不是一棵树。边的信息以(start , end)的形式给出.


题目分析:

               这道题可以用并查集来做,也可以直接使用树的定义来做即可。以下给出使用树的定义来做的解题思路。

树的定义:

1)一个具有n个结点的数,最多只有n-1个结点

2)一棵树有且只有一个入度为0的结点,并且所有结点的入度都不大于1.

其中条件1)已经能有条件2)保证。所以在编码的时候,主要针对条件2)进行变么即可


代码如下:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>


using namespace std;

const int maxn = 1005;

struct Edge {//边
	int start;//起点
	int end;//终点
} edges[maxn];

int indegree[maxn];//某一个点的入度

/**
 * 判断一个队列q里面是否包含某一个数a
 */
bool isContain(queue<int> q,int a){

	while(!q.empty()){//如果该队列非空
		int temp = q.front();//则不断地遍历该队列
		q.pop();

		if(temp == a){//如果包含数a
			return true;//则返回true
		}
	}

	return false;
}


int main() {
	int a, b;
	int counter;
	int caseNum = 1;

	while (cin >> a >> b) {//注意这种数据的读取方式
		queue<int> q;//用来保存这个图中出现过的点

		if (a < 0 && b < 0) {
			break;
		}


		counter = 0;//初始化边数
		memset(indegree, 0, sizeof(indegree));//初始化每个点的入度.默认初始化为0

		while (a != 0 && b != 0) {
			if(isContain(q,a) == false){//如果q中还没有出现过a
				q.push(a);//则将a入队
			}

			if(isContain(q,b) == false){
				q.push(b);
			}

			edges[counter].start = a;//记录边的信息
			edges[counter].end = b;
			indegree[edges[counter].end]++;//记录每个点的入度
			counter++;

			cin >> a >> b;
		}

		bool flag = true;//用于标记这是否是一棵树
		int root = 0;//入度为0的点的个数

		while (!q.empty()) {
			int temp = q.front();
			q.pop();



			if (indegree[temp] == 0) {//如果改点的入度为0
				root++;//则入度为0的点的数目+1
			}

			if (indegree[temp] > 1) {//如果改点的入度>1
				flag = false;//则证明该图不是一棵树.(因为树中不存在入度>1的结点)
				break;
			}

		}


		if (root > 1) {//如果入度为0的结点的数目>1
			flag = false;//则证明该图不是一棵树
		}


		if (flag == true) {
			cout << "Case " << (caseNum++) << " is a tree." << endl;
		} else {
			cout << "Case " << (caseNum++) << " is not a tree." << endl;
		}
	}

	return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值