LIS poj 1065

 Wooden Sticks

 

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

题意:给出(l,w)的木棍,机器可以加工(l'>=l,w'>=w)的木棍,每调一次机器需要1分钟,问最少需要多长时间。

题解:实质是让求有多少上升子序列,先对l进行排序,然后查找子序列,并更新原数组的首元素,每找到一个子序列,cnt++。

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct node{
	int l,w;
}st[5050],la;

bool cmp(node a,node b){
	if (a.l==b.l)
	return a.w <b.w;
	return a.l<b.l;
}
int vis[5050];
int main(){
	int t,n,i,j,cnt;
	scanf ("%d",&t);
	while (t--){
		cnt=0;
		memset(vis,0,sizeof(vis));
		scanf ("%d",&n);
		for (i=0;i<n;i++){
			scanf ("%d %d",&st[i].l,&st[i].w);
		}
		sort(st,st+n,cmp);
		for (i=0;i<n;i++){
			la.w=st[i].w;
		if (!vis[i]){//防止重复访问
			for (j=i+1;j<n;j++){
				if (la.w<=st[j].w && !vis[j]){
					vis[j]=1;
					la.w=st[j].w;//把该木棍作为下一次查找的参照
				}	
			}
		cnt++;	
		}	
		}
		printf ("%d\n",cnt);

	}
	return 0;
}</span>

还有1个神奇的思路
这道题的要求其实是将所有stick分为x个不下降子序列( Ai <= Ai+1 ),然后问题归结于求x的最小值。 x的最小值其实等于按l递增排序后stick按w最长下降子序列的长度L。(没看懂)


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值