DP之LIS POJ 2533

先上一道模板题:
A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

还是那句话 状态转移方程:dp[i](表示以s[i]结尾的最长上升子序列)=max(dp[j]+1)  (j<I&&a[j]<a[i])

Talk is cheap,show you the AC code:

#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f
const int N=10010;
using namespace std;
int s[N],dp[N];
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
		cin>>s[i];
	for(int i=1;i<=n;i++)
		dp[i]=1;
	int wyh=1;
	for(int i=1;i<=n;i++)
		{
			for(int j=1;j<i;j++)
		{
			if(s[j]<s[i])
			dp[i]=max(dp[i],dp[j]+1);
		}
		wyh=max(wyh,dp[i]);
		
	}
		cout<<wyh<<endl;


	return 0;
}

这是纯粹的一种dp方法,但是这其中的二重循环将复杂度大大提高。所以便有了二分优化的代码:

#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f
const int N=10010;
using namespace std;
int s[N],dp[N];
int erfen(int *a,int r,int x)
{
	int l=1,mid;
	while(l<=r)
	{
		mid=(l+r)/2;
		if(a[mid]>x)
			r=mid-1;
		else
			l=mid+1;
	}
	return l;
}
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
		cin>>s[i];
	for(int i=1;i<=n;i++)
		dp[i]=INF;
	int wyh=1;
	dp[1]=s[1];
	for(int i=1;i<=n;i++)
	{
		if(s[i]>dp[wyh])
		{
			wyh++;
			dp[wyh]=s[i];
		}
		else {
			dp[erfen(dp,wyh,s[i])]=s[i];
		}
	}
	cout<<wyh<<endl;


	return 0;
}
这种方法for循环中dp[i]全部定义为INF也即一个很大的数,而第一种则是1.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值