poj 3614(Best Cow Line)

 贪心

Best Cow Line

 

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD


题意:给定长度为n的字符串s,要构造一个字符串T,每次可以有两种操作,取s串的头或尾加入T的尾部,求构成的最小字典序的T。

题解:

贪心,首先想到的是每次比较s的头尾选取,但是若头尾相同,则需要比较下一个字符,而下一个字符也可能相同,所以可以采用字符串反转的方法。每次比较s和s',s小得话选s的开头,s'小的话选s的末尾。还要注意输出,80字符换行。

#include<cstdio>
#include<cstring>
using namespace std;
	char s[2020];
	char map[2020];
int main(){
	int n;
	int i;
	scanf ("%d",&n);
	for (i=0;i<n;i++){
		scanf ("%s",map);
		s[i]=map[0];
	}
	int a=0;
	int b=n-1;
	int cnt=0;
	while (a<=b){//将从左起和从右起的字符比较
		bool left =false;
		for (i=0;a+i<=b;i++){
			if (s[a+i]<s[b-i]){//左<右
				left =true;cnt++;	
				break;
			}
			else if (s[a+i]>s[b-i]){//左>右
				left =false;cnt++;
				break;
			}
			
		}
		if (left)
			putchar(s[a++]);//取左侧值
		else
			putchar(s[b--]);//取右侧值
		if (cnt%80==0)
			putchar ('\n');
	}
	if (cnt%80)
		putchar ('\n');
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值