N!Again hdu 2674 c++

 

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3434    Accepted Submission(s): 1863


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 


 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 


 

Output
For each case, output N! mod 2009
 


 

Sample Input
  
  
4 5
 


 

Sample Output
  
  
24 120
 

题意:给定n,求n的阶乘对2009 取余的结果;
分析:水题,给定n的范围看似很大。当n! >2009 时,其阶乘必定含2009 对2009取余必为0,小于2009时 直接算即可。打表可得超过41的阶乘均大于2009.

代码如下:

#include<cstdio>
#include<cstring>

int main()
{
    __int64 i,s,n;
    while(scanf("%I64d",&n)!=EOF)
    {
       
       if(n==0)
           printf("1\n");
       else if(n>41)
           printf("0\n");    
       else 
       {
            s=1;
            for(i=n;i>0;i--)
            {
               s*=i;
               s=s%2009;
            }   
           printf("%d\n",s);
       }
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值