HDU 1506 Largest Rectangle in a Histogram(DP)

http://acm.hdu.edu.cn/showproblem.php?pid=1506


Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9523    Accepted Submission(s): 2623


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000
 

Source
 


求出直方图中最大矩形面积



对每条柱子向左右两边求出最远到达的距离

假设当前柱子为第i个,如果第i-1个(已求出)比i高,那么i-1向左最远到达处i一定能到达,然后再向左一格考察

所以有l[i-1]=l[l[i]-1],a[l[i]-1]>=a[i](l[i]为向左最远到达处,初始值为i,a[i]为当前柱子高度)

右侧同理


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<queue>
#include<vector>
#define sqr(x) (x)*(x)
#define INF 0x1f1f1f1f
#define PI 3.1415926535
#define LL long long
#define mm  100005

using namespace std;

LL a[mm],maxarea;
int n,i,j,l[mm],r[mm];

void solve()
{
	for (i=1;i<=n;i++)
	{
		
		while (l[i]-1>0 && a[l[i]-1]>=a[i])	//这里要注意判 l[i]-1>0,我在这里TLE无数次,下面同理 
		{
			l[i]=l[l[i]-1];
		}
		
	}
	
	for (i=n;i>0;i--)
	{
		
		while (r[i]+1<=n && a[r[i]+1]>=a[i])
		{
			r[i]=r[r[i]+1];
		}

	}

	maxarea=0;
	for (i=1;i<=n;i++)
	{
		a[i]=a[i]*(r[i]-l[i]+1);
		maxarea=max(maxarea,a[i]);
	}
	printf("%I64d\n",maxarea);
}

int main()
{
	while(scanf("%d",&n)&&n)
	{
		
		for (i=1;i<=n;i++)
		{
			scanf("%I64d",&a[i]);
			l[i]=r[i]=i;
		}
		
		solve();
	}
	
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值