HDU - 1506 - Largest Rectangle in a Histogram (单调栈)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
这里写图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000

这是个十分经典的单调栈的应用,给你一个图,在一个数轴上,每一单位长度都有一个高度,让你求这个图形里面哪几行构成的矩形最大,这样维护两个递减的单调栈,这样可以使得某行的高度连续多宽都被记录下来。一一比较就可以了。

AC代码:

#include<cstdio>
#include<iostream>
#include<stack>
#define maxn 100010
using namespace std;
int a[maxn], l[maxn], r[maxn];

int main()
{
    long long n;

    while(scanf("%lld", &n), n)
    {
        stack<int> s, t;
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        for(int i = 1; i <= n; i++)
        {
            while(s.size() && a[s.top()] >= a[i])   s.pop();
            if(s.empty())   l[i] = 0;
            else    l[i] = s.top();
            s.push(i);
        }
        for(int i = n; i >= 1; i--)
        {
            while(t.size() && a[t.top()] >= a[i])   t.pop();
            if(t.empty())   r[i] = n+1;
            else    r[i] = t.top();
            t.push(i);
        }

        long long _max = 0;
        for(int i = 1; i <= n; i++)
        {
            long long w = r[i]-l[i]-1;
            long long ar = w*a[i];
            _max = max(_max, ar);
        }
        printf("%lld\n", _max);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值