POJ 1905 Expanding Rods(二分)

http://poj.org/problem?id=1905


Expanding Rods
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10655 Accepted: 2724

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

Source




如图,原来长L的直棒变成长L'的弧,求偏移量(就是弧中点到弦的距离,实在不知道是哪个术语>_<)


高中数学问题,画个弦、弧所对应的扇形(数形结合),列出关于弧所对圆心角的方程(化归转移),发现是个超越方程,不会解,变成函数(函数方程),用二分求零点,然后再求出偏移量


本题要注意精度(PI和角度),当n*c=0时直接输出0.000,用MinGW GCC输出用%f


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<queue>
#include<vector>
#define sqr(x) (x)*(x)
#define INF 0x1f1f1f1f
#define PI 3.14159265358979
#define LL long long
#define mm 

using namespace std;

double l,n,c,cital,citar,l_,a;	//cital,citar 角度的下界与上界,l_弧长,a偏移量 

double ans(double x)
{
	return l_/2/x*(1-cos(x));	//算偏移量,公式自己推 
	
}

double fun(double x)	
{
	return x/sin(x)-l_/l;		//二分函数 
}


int main()
{
	while(scanf("%lf %lf %lf",&l,&n,&c)&&(l!=-1)&&(n!=-1)&&(c!=-1))
	{
		l_=(1+n*c)*l;
		
		cital=0;
		citar=PI;
		
		if (n*c<1e-8)
		{
			printf("0.000\n");
			continue;
		}
		
		while (cital<citar)
		{
			double mid=(cital+citar)/2;
			double y=fun(mid);
			
			if (fabs(y)<1e-12)
			{
				a=ans(mid);
				break;
			}
			else
			{
				if (y>0)
				{
					citar=mid;
				
				}
				else
				{
					cital=mid;
				}
				if (fabs(ans(citar)-ans(cital))<1e-5)
				{
						a=ans(citar);
						break;
				}
				
			}
		} 
		printf("%.3f\n",a);
		
	}
	
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值