HDU 2818 Building Block(并查集)

http://acm.hdu.edu.cn/showproblem.php?pid=2818

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2538    Accepted Submission(s): 777


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command. 
C X : Count the number of blocks under block X 

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 

Source
 


开个数组under记录x下方有多少个方块,在找根的时候更新就好,under[x]+=under[pre[x]]

合并的时候under[rx]=num[ry],其中num[ry]记录以ry为根时,这棵树的节点数量

输出前记得先root一下



#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#define sqr(x) (x)*(x)
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.14159265358979
#define eps 1e-10
#define mm 30001

using namespace std;

int pre[mm],under[mm],num[mm];

void init()
{
         for (int i=0;i<mm;i++)
         {
                  pre[i]=i;
                  num[i]=1;
         }

         memset(under,0,sizeof(under));


}

int root(int x)
{
         if (pre[x]==x)
         {
                  return x;
         }

         /*
         下面是关键代码
         */

         int t=root(pre[x]);
         under[x]+=under[pre[x]];
         pre[x]=t;

         return t;
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("t","r",stdin);
	#endif

	int p;
	char op;
	int x,y;
	int rx,ry;

	scanf("%d",&p);getchar();
	init();

	while (p--)
         {
                  op=getchar();

                  if (op=='M')
                  {
                           scanf("%d%d",&x,&y);
                           rx=root(x);
                           ry=root(y);

                           if (rx!=ry)
                           {
                                   pre[rx]=ry;
                                   under[rx]=num[ry];
                                   num[ry]+=num[rx];
                           }

                  }
                  else
                  {
                           scanf("%d",&x);
                           root(x);
                           printf("%d\n",under[x]);
                  }

                  getchar();
         }


	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值