HDU 2795 Billboard(线段树)

http://acm.hdu.edu.cn/showproblem.php?pid=2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9522    Accepted Submission(s): 4240


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 


题意:
有一块高h宽w的展板,有n张通知要贴(按给出的顺序),每张通知高1宽wi,要求每张通知尽量贴在高出,并且左对齐,求出每张通知在哪一行贴出,如果无法贴出,输出-1。

分析:
每行已占用的宽度为当前行维护的值,我们只要找出一个能容纳的宽wi的最高的那行。采用线段树,维护区间内的最值(将板子逆时针选转90度)。若w-max[l,r)<=wi,说明[l,r)这个区间内的所有位置都可容纳wi,ans=min(ans,l);若w-min[l,r)<wi, 说明这个区间内所有位置都不能容纳wi;如果前两种情况都不满足,则递归检查更新ans。

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define mm 200000

using namespace std;

int h,w;
int _max[mm<<2];
int _min[mm<<2];
int rec[mm];

void update(int p,int v,int k,int l,int r)
{
    if (r-l==1)
    {
        _max[k]=_min[k]=v;
        return ;
    }

    int m=l+r>>1;
    if (p<m)    update(p,v,k*2+1,l,m);  else    update(p,v,k*2+2,m,r);
    _max[k]=max(_max[k*2+1],_max[k*2+2]);
    _min[k]=min(_min[k*2+1],_min[k*2+2]);
}

void query(int v,int k,int l,int r,itn &ans)
{
    if (v>w-_min[k])    return ;

    if (v<=w-_max[k])
    {
        ans=min(l,ans);
        return ;
    }

    if (r-l==1) return ;

    int m=l+r>>1;
    query(v,k*2+1,l,m,ans);
    if (ans<m)  return ;    //重要剪枝
    query(v,k*2+2,m,r,ans);
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("/home/fcbruce/文档/code/t","r",stdin);
    #endif // ONLINE_JUDGE

    int n,v,ans,p;

    while (~scanf("%d %d %d",&h,&w,&n))
    {
        int _n=min(n,h);    //最多这么多行啦,如果h>n就都浪费啦
        for (int i=0;i<_n;i++)
            update(i,0,0,0,_n),rec[i]=0;

        while (n--)
        {
            scanf("%d",&v);
            ans=INF;
            query(v,0,0,_n,ans);
            if (ans!=INF && w-rec[ans]>=v)
            {

                printf("%d\n",ans+1);
                rec[ans]+=v;
                update(ans,rec[ans],0,0,_n);

            }
            else
            {
                puts("-1");
            }
        }
    }


    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值