poj 3661

Running

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 4940

Accepted: 1829

Description

The cows are trying to become better athletes, soBessie is running on a track for exactly N (1  N  10,000) minutes. During eachminute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though,depends on her 'exhaustion factor', which starts at 0. When she chooses to runin minute i, shewill run exactly a distance of Di (1  Di  1,000) and her exhaustionfactor will increase by 1 -- but must never be allowed to exceed M (1  M  500). If she chooses to rest,her exhaustion factor will decrease by 1 for each minute she rests. She cannotcommence running again until her exhaustion factor reaches 0. At that point,she can choose to run or rest.

At the end of the N minuteworkout, Bessie's exaustion factor must be exactly 0, or she will not haveenough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessiecan run while satisfying the conditions.

Sample Input

52
5
3
4
2
10

Sample Output

9

 

题意:N分钟,小刚每分钟可以选择是停下休息还是往前走,如果选择往前走的话可以在第i分钟走Di,当然,小刚的疲劳值也会增加1。如果选择休息则小刚的疲劳值会每分钟减小1,当小刚停下来以后,小刚只能在疲劳值降到0时才能继续再走。已知小刚的疲劳值最多不能超过M,当小刚度过N分钟后要保证他的疲劳值为0,问小刚最多能走多长的距离。

分析:先设dp[i][j]表示小明在i分钟,疲劳值为j时所能走的最远距离(此时第i分钟已经过完,即第i分钟完成时,疲劳度为j)

a)、先看dp[i][0]的情况,表示第i分钟时,疲劳值为0,考虑这个值由哪些情况得到,

1、dp[i][0] = dp[i-1][0],这个没有任何问题。

2、dp[i][0] = dp[i-j][j]。表示i-j分钟时的疲劳值为j,然后一直休息j分钟把疲劳值降成0。

b)、现在考虑dp[i][j]的情况,它可以由dp[i-1][j-1] +Di得到,表示第i分钟选择走Di。因为要保证没有后效性,所以只有这一种情况可以转移。

 

#include<iostream>
usingnamespace std;
#define Max10005
intdp[Max][505];
int a[Max];
 
int main()
{
    int n,m;
    while(cin>>n>>m){
        for ( int i=1; i<=n; ++i ){
            cin>>a[i];
        }
        memset(dp,0,sizeof(dp));
 
        for ( int i=1; i<=n; ++i ){
            for ( int j=1; j<=m &&j<=i; ++j ){
                dp[i][j]=dp[i-1][j-1]+a[i];
            }
 
            dp[i][0]=dp[i-1][0];
 
            for ( int j=1; j<=m &&i-j>=j;++j ){
               dp[i][0]=max(dp[i-j][j],dp[i][0]);
            }
        }
        cout<<dp[n][0]<<endl;
    }
  
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值