POJ 2002 Square

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

题意:平面上给定n个点,求由这些点能构成多少个正方形。

考察点:计算几何,二维点哈希

分析:我们枚举两个点,那么在这两个点形成的直线两边可以计算出正方形的另外两个点,利用Hash然后查找即可。由于一个正方形的边都会被遍历,所以最终答案需要除以4.

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
typedef long long LL;
const int N = 1005;
const int H = 10007;

struct Point
{
    int x,y;
};

Point p[N];

struct Node
{
    int x,y;
    int next;
};

Node node[N];
int cur,n;
LL ans;

int Hash[H];

void Init()
{
    for(int i=0;i<H;i++)
       Hash[i] = -1;
    cur = ans = 0;
}

void Insert(int x,int y)
{
    int h = (x * x + y * y) % H;
    node[cur].x = x;
    node[cur].y = y;
    node[cur].next = Hash[h];
    Hash[h] = cur++;
}

bool Search(int x,int y)
{
    int h = (x * x + y * y) % H;
    int t = Hash[h];
    while(t != -1)
    {
        if(x == node[t].x && y == node[t].y) return true;
        t = node[t].next;
    }
    return false;
}

LL Work()
{
    Init();
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&p[i].x,&p[i].y);
        Insert(p[i].x,p[i].y);
    }
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            int x1 = p[i].x - (p[i].y - p[j].y);
            int y1 = p[i].y + (p[i].x - p[j].x);
            int x2 = p[j].x - (p[i].y - p[j].y);
            int y2 = p[j].y + (p[i].x - p[j].x);
            if(Search(x1,y1) && Search(x2,y2)) ans++;
        }
    }
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            int x1 = p[i].x + (p[i].y - p[j].y);
            int y1 = p[i].y - (p[i].x - p[j].x);
            int x2 = p[j].x + (p[i].y - p[j].y);
            int y2 = p[j].y - (p[i].x - p[j].x);
            if(Search(x1,y1) && Search(x2,y2)) ans++;
        }
    }
    ans >>= 2;
    return ans;
}

int main()
{
    while(~scanf("%d",&n),n)
        printf("%I64d\n",Work());
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值