hdu2124--Repair the Wall(贪心水题)

Repair the Wall

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2158    Accepted Submission(s): 1057


Problem Description
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
 

Input
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The i th integer Ai(0<Ai<1000000000 ) means that the i th block has the size of 1×Ai (in inch).
 

Output
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
 

Sample Input
  
  
5 3 3 2 1 5 2 2 1
 

Sample Output
  
  
2 impossible
题目大意:下大雨somebody的墙会毁坏,毁坏的面积为1 * L(inch),现在有砖块宽为1 inch,长即为输入的那些数字,看到这直觉应该很舒服的,因为毁坏的宽或长也为1 inch,也就是说可以只考虑一边了,由于数略大,必须用64位long long才能过,本题就是一个裸贪心,先排个序,由大到小排序,先选大的去补,需要的块数就少。下面是代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn = 650;
long long a[maxn];
bool cmp(int a,int b)//由大到小排序
{
    return a>b;
}
int main()
{
    long long m,sum;
    int n,cnt;
    //freopen("1.in","r",stdin);
    while(cin>>m>>n)
    {
        sum = 0;
        cnt = 0;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        sort(a+1,a+n+1,cmp);
        while(sum<m && cnt<=n)  //如果小于目标就再加且如果还有剩余的砖块
        {
            sum += a[cnt+1];
            cnt++;
        }
        if(cnt<=n)
            cout<<cnt<<endl;
        else if(sum<m || cnt >= n)  //所有砖块用完了
            cout<<"impossible"<<endl;
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值