网络流之最大流(Edmonds-Karp算法和Dinic算法)

Ford-Fulkerson算法的基本思路:

Ford-Fulkerson算法是求解最大流的基本算法,主要思想是,每次在残量网络中寻找一条从源到汇的路径(称为增广路径),并沿着这条路径增加流量,该算法的改进为Edmonds-Karp算法,与Ford-Fulkerson算法基本无异。Edmonds-karp算法的复杂度为O(|V|*|E|²),在稀疏图(边少点多)中可以得到不错的运行效率。

算法流程:

设s为源,t为汇,C为容量矩阵,F为流量矩阵,f为最大流量

输入:流网络G

输出:网络的最大流

具体流程:

①初始化F,f.

②使用BFS在残量网络中找到一条从s到t的最短增广路T,如果最短增广路不存在,算法结束。

③计算m = min(u,v)∈T C(u,v) - F(u,v)

④f增加m

⑤沿着T修改流量矩阵,对于任意(u,v)∈T,将F(u,v)增加m,F(v,u)减少m

⑥重复步骤②

例题:来自杭电1532

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10310    Accepted Submission(s): 4903


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
   
   
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
   
   
50

Edmonds-karp实现代码:

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<vector>
using namespace std;
const int maxn = 201;
int inf = 0x7fffffff;
int capacity[maxn][maxn]; //记录残留网络的容量
int flow[maxn];   //标记从源点到当前节点实际还剩多少流量可用
int pre[maxn]; //标记在这条路径上当前节点的前驱,同时标记该节点是否在队列中

int n,m;
queue<int> que;
int BFS(int src,int des)
{
    int i,j;
    while(!que.empty())  //队列清空,因为可能不止一次执行这个函数
    {
        que.pop();
    }
    for(i=1;i<=m;i++)
    {
        pre[i] = -1;   //初始化前驱都为-1
    }
    pre[src] = 0;  //src为1,前驱置为0
    flow[src] = inf;
    que.push(src);
    while(!que.empty())
    {
        int index = que.front();
        que.pop();
        if(index == des)  //找到了增广路径
            break;
        for(i=1;i<=m;i++)
        {
            if(i!=src && capacity[index][i] >0 && pre[i] == -1)  //容量不为0
            {
                pre[i] = index; //记录前驱
                flow[i] = min(capacity[index][i],flow[index]);  //迭代找到增量
                que.push(i);
            }
        }
    }
    if(pre[des] == -1)  //残留图中不再存在增广路
    {
        return -1;
    }
    else
    {
        return flow[des];
    }
}
int maxFlow(int src,int des)
{
    int increase = 0;
    int sumflow = 0;
    while((increase = BFS(src,des)) != -1)
    {
        int k = des; //利用前驱寻找路径
        while(k != src)
        {
            int last = pre[k];
            capacity[last][k] -= increase; //改变正向边的容量
            capacity[k][last] += increase; //改变反向边的容量
            k = last;
        }
        sumflow += increase;
    }
    return sumflow;
}
int main()
{
    int i,j;
    int start,end,num;
    //freopen("111","r",stdin);
    while(cin>>n>>m)
    {
        memset(capacity,0,sizeof(capacity));
        memset(flow,0,sizeof(flow));
        for(i=0;i<n;i++)
        {
            cin>>start>>end>>num;
            if(start == end)
                continue;
            capacity[start][end] += num;
        }
        cout<<maxFlow(1,m)<<endl;
    }
    return 0;
}


Dinic算法实现代码:

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int inf = 0x7fffffff;
const int maxn = 20000,maxm = 500000;

struct Edge
{
    int v,f,nxt;
};
int n,src,sink;
int g[maxn + 10];
int nume;
Edge e[maxm * 2 + 10];

void addedge(int u,int v,int c)
{
    e[++nume].v = v;
    e[nume].f = c;
    e[nume].nxt = g[u];
    g[u] = nume;
    e[++nume].v = u;
    e[nume].f = 0;
    e[nume].nxt = g[v];
    g[v] = nume;
}

void init()
{
    memset(g,0,sizeof(g));
    nume = 1;
}

queue<int> que;
bool vis[maxn + 10];
int dist[maxn + 10];

void bfs()
{
    memset(dist,0,sizeof(dist));
    while(!que.empty())
    {
        que.pop();
    }
    vis[src] = true;
    que.push(src);
    while(!que.empty())
    {
        int u = que.front();
        que.pop();
        for(int i=g[u];i;i = e[i].nxt)
        {
            if(e[i].f && !vis[e[i].v])
            {
                que.push(e[i].v);
                dist[e[i].v] = dist[u] + 1;
                vis[e[i].v] = true;
            }
        }
    }
}

int dfs(int u,int delta)
{
    if(u == sink)
    {
        return delta;
    }
    else
    {
        int ret = 0;
        for(int i=g[u];delta && i;i = e[i].nxt)
        {
            if(e[i].f && dist[e[i].v] == dist[u] + 1)
            {
                int dd = dfs(e[i].v,min(e[i].f,delta));
                e[i].f -= dd;
                e[i^1].f += dd;
                delta -= dd;
                ret += dd;
            }
        }
        return ret;
    }
}

int maxflow()
{
    int ret = 0;
    while(true)
    {
        memset(vis,0,sizeof(vis));
        bfs();
        if(!vis[sink]) return ret;
        ret += dfs(src,inf);
    }
}

int main()
{
    int m;
    int start,end,num;
    //freopen("111","r",stdin);
    while(cin>>m>>n)
    {
        init();
        src = 1;
        sink = n;
        for(int i=0;i<m;i++)
        {
            cin>>start>>end>>num;
            if(start == end)
            {
                continue;
            }
            addedge(start,end,num);
        }
        cout<<maxflow()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值