POJ2342 Anniversary party(树形DP)

Anniversary party

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4850 Accepted: 2751

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input


7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5


题目大意:

大学教工聚会,每个人都有自己的快乐值,但是每个人并不想和他的直接上级一起出席,现在要求怎么安排才能使整个聚会的快乐值最多。

解题思路:

利用树形动态规划,树形DP其实就是在一棵树上用DP罢了,我们假设dp[i][1]表示第i个人会出席聚会,dp[i][0]表示第i个人不会出席聚会,很容易写出下列的状态转移方程

dp[v][1] = dp[u][0] + val[v] 或者 dp[v][0] = max(dp[u][0],dp[u][1]),其中v为u的上级,也就是v是u的父结点,第一种情况是v出席的情况,第二种是v不出席的情况。

代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 6010;
int dp[maxn][2];
int father[maxn]; //记录每个结点的父亲
int vis[maxn];
int m;

void tree(int root)
{
    int i;
    vis[root] = 1;
    for(i=1;i<=m;i++)
    {
        if(!vis[i] && father[i] == root)
        {
            tree(i);
            dp[root][1] += dp[i][0]; //root去,i不能去
            dp[root][0] += max(dp[i][0],dp[i][1]);
        }
    }
}

int main()
{
    int num1,num2;
    int root;
    int i;
    int res;
    //freopen("111","r",stdin);
    while(cin>>m)
    {
        root = 0;
        for(i=1;i<=m;i++)
        {
            cin>>dp[i][1];
        }
        while(cin>>num1>>num2 && num1 + num2 > 0)
        {
            father[num1] = num2; //num1的上司是num2
            root = num2;
        }
        memset(vis,0,sizeof(vis));
        tree(root);
        res = max(dp[root][1],dp[root][0]);
        cout<<res<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值