POJ2243 Knight Moves(A*算法)

Knight Moves
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12345 Accepted: 6963

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


题目大意:

国际象棋,马跳日,有八个方向,求由给定起点到给定终点最少的步数。

解题思路:

刚学A*算法,拿来用,A*算法其实是dijkstra最短路算法和BFS(广搜)的结合,由于dijkstra算法和BFS算法可能存在盲目搜索,占用太多时间,所以产生了A*算法,A*算法常用来做游戏,游戏中大多数寻路都是用A*来做的,比如LOL你点地图的任意位置时,细心观察一下系统给你指明了一条最短的路径,在右下角的小地图可以看到,不信你可以找找还有哪条路径更优。在A*算法中有一公式,f(n)=g(n) + h(n),g(n)代表起点到任意一个结点n的移动耗费,h(n)为结点n到终点的估价值,这个估价值曼哈顿估价函数来计算,即为曼哈顿距离*10,二维曼哈顿距离公式 = |终点.x - 当前点.x| + |终点.y - 当前点.y|.我可以知道,BFS其实就是h(n) = 0的A*算法,所以我们可以把它称作最烂的A*算法,并没有用到启发式。而dijkstra算法的g(n) = 0,它只是从起点到终点用启发式罢了,所以我们现在把两者结合再一起就是A*算法。估价函数很明显我们选择最小的,所以我们用最小堆(STL里面的优先队列)来维护最小值,然后每次取最优解,一直迭代直到到达目标.

代码:

#include<iostream>
#include<queue>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
using namespace std;

struct knight
{
    int x,y,step;
    int g,h,f;
    bool operator < (const knight &k) const
    {
        return f > k.f;
    }
}k;

bool visited[8][8];
int x2,y2,ans; //起点(x1,y1),终点(x2,y2),最少移动次数ans
int dir[8][2] = {{-2,-1},{-2,1},{2,-1},{2,1},{-1,-2},{-1,2},{1,-2},{1,2}};
priority_queue<knight> que; //最小优先队列(开启列表)

bool in(const knight &a) //判断knight是否在棋盘内
{
    if(a.x < 0|| a.y <0 || a.x >= 8 || a.y >= 8)
    {
        return false;
    }
    return true;
}

int Heuristic(const knight &a) //曼哈顿估价函数
{
    return (abs(a.x - x2) + abs(a.y - y2)) * 10;
}

void Astar() //A*算法
{
    knight t,s;
    while(!que.empty()) //如果开启列表不为空
    {
        t = que.top();
        que.pop();
        visited[t.x][t.y] = true;
        if(t.x == x2 && t.y == y2) //如果到达目的地
        {
            ans = t.step;
            break;
        }
        for(int i=0;i<8;i++)
        {
            s.x = t.x + dir[i][0];
            s.y = t.y + dir[i][1];
            if(in(s) && !visited[s.x][s.y])
            {
                s.g = t.g + 23; //23表示根号5乘以10再取其ceil(向上取整)
                s.h = Heuristic(s); //曼哈顿估价函数
                s.f = s.g + s.h;
                s.step = t.step + 1;
                que.push(s);
            }
        }
    }
}

int main()
{
    char line[5];
    int x1,y1;
    //freopen("111","r",stdin);
    while(gets(line))
    {
        x1 = line[0] - 'a'; //起点
        y1 = line[1] - '1';
        x2 = line[3] - 'a';//终点
        y2 = line[4] - '1';
        memset(visited,false,sizeof(visited));
        k.x = x1;
        k.y = y1;
        k.g = k.step = 0;
        k.h = Heuristic(k);
        k.f = k.g + k.h;
        while(!que.empty()) que.pop();
        que.push(k);
        Astar();
        printf("To get from %c%c to %c%c takes %d knight moves.\n",line[0],line[1],line[3],line[4],ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值