The ? 1 ? 2 ? ... ? n = k problem

 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
承认这个题有点剽窃别人思路的嫌疑,这个一开始没思路后来,听见有人讨论这个应该先把数开到最大再说。我就明白怎么做了,因为数小不可能有表达式能完成这个数嘛~
你也懂了?好吧,我知道。后面的工作吗,就是我自己想的了,你也可以的哦。
如果还不知道,那就举个例子吧,如果你和我都有两个苹果,你给我一个,那么咱俩差几个,答案是2个,那么同样的,我们要先变大,后变小变小应该是2倍的那个数,所以我们变大的那个数与要完成的那个数的被减数应该是个偶数
#include<stdio.h>
#include<math.h>
int main()
{
    int n,i;
    scanf("%d",&n);
    for(i=1; i<=n; i++)
    {
        int a;
        scanf("%d",&a);
        int j;
        for(j=1;; j++)
        {
            if(j*(j+1)>=abs(2*a))
            {
                if((j*(j+1)/2-abs(a))%2==0)
                {
                    printf("%d\n",j);
                    break;
                }
            }
        }
        if(i!=n)
            printf("\n");
    }
            return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值