A1002 A+B for Polynomials

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

//本算法利用同一数组进行计算,较简便,满分
#include <stdio.h>
#define N 1001
int main(){
    float a[N] = { 0 };
    int k, e;
    float c;
    int cnt = 0;
    scanf("%d", &k);
    for (int i = 0; i < k; i++){
        scanf("%d %f", &e, &c);
        a[e] += c;
    }
    scanf("%d", &k);
    for (int i = 0; i < k; i++){
        scanf("%d %f", &e, &c);
        a[e] += c;
    }
    for (int i = 0; i < N; i++){
        if (a[i] != 0){
            cnt++;
        }
    }
    printf("%d", cnt);
    for (int i = N-1; i >= 0; i--){
        if (a[i] != 0){
            printf(" %d %.1f", i, a[i]);     //不必在最后一个数后加回车
        }
    }

    return 0;
}
//本算法利用三个数组,较繁琐,且有漏洞(哪位大神不吝指教,不胜感激~),23分
#include <stdio.h>
#define N 1001
int main(){
    int k1;
    scanf("%d", &k1);
    float a[N] = { 0 }, b[N] = { 0 };

    for (int i = 0; i < 2 * k1; i++){
        scanf("%f", &a[i]);
    }
    int k2;
    scanf("%d", &k2);
    for (int i = 0; i < 2 * k2; i++){
        scanf("%f", &b[i]);
    }

    float c[N] = { 0 };
    int i = 0, j = 0, k = 0;
    while (i < N - 1){
        if (a[i] == b[j]){
            if (a[i + 1] != 0 || b[j + 1] != 0){
                c[k] = a[i];
                c[k + 1] = a[i + 1] + b[j + 1];
                if (c[k + 1] != 0){
                    k += 2;
                }
                i += 2;
                j += 2;
            }
            else{
                break;
            }
        }
        else{
            if (a[i] < b[j]){
                c[k] = b[j];
                c[k + 1] = b[j + 1];
                j += 2;
            }
            else{
                c[k] = a[i];
                c[k + 1] = a[i + 1];
                i += 2;
            }
            k += 2;
        }
    }
    printf("%d ", k/2);
    for (int t = 0; t < k-1; t++){
        if (t % 2 == 0){
            printf("%d ", (int)c[t]);
        }
        else{
            printf("%.1f ", c[t]);
        }
    }
    printf("%.1f\n", c[k-1]);     //最后一行加回车
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值