PAT-A1002 A+B for Polynomials (多项式加法)

A1002 A+B for Polynomials (多项式加法)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5结尾无空行

Sample Output:

3 2 1.5 1 2.9 0 3.2

结尾无空行

题意:

一个test包含两行,每行各输入一个多项式,第一个数是代表该多项式的非零项数,接下来两个是该项的指数和系数,最后输出两个多项式的和的非零项数以及各项的指数和系数。

分析:

ps:作为一个不留余力的踩坑小能手,我基本上所有的坑都踩到了o(╥﹏╥)o,心好累

本题参考了《算法笔记》的方法,为了降低时间复杂度,没有一次性全部进行输入(这种思想挺好的,在后面的几道题中都有用到())

  1. 新建一个double数组 double ploy[maxn]={},该数组的下标表示指数,下标对应的值表示系数。
  2. 接收输入的指数和系数的值,累加求和
  3. 遍历找出两多项式的非零项个数
  4. 遍历输出结果

相关注意:

  1. double ploy[maxn]={};//注意要加{}
  2. double用%lf来接收,输出小数点一位用%.1f
  3. double数组为maxn,下标从0开始,所以遍历的时候要i=maxn-1
  4. 最后判断条件 if(ploy[i]!=0) 注意是!=0,不能是>0,否则测试点会有通不过

代码如下:

#include<cstdio>
const int maxn=1005;
int main(){
	//注意要加{} 
	double ploy[maxn]={};
	int k,z;
	double x;
	int count=0;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&z,&x);
		ploy[z]+=x;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %lf",&z,&x);
		ploy[z]+=x;	
		}
	for(int i=0;i<maxn;i++){
		if(ploy[i]!=0) count++;
	}
	printf("%d",count);
	//注意maxn-1 
	for(int i=maxn-1;i>=0;i--){//是1不是l 
		if(ploy[i]!=0) printf(" %d %.1f",i,ploy[i]);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值