POJ 2418 Hardwood Species(字典树)

Hardwood Species
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 20085 Accepted: 7911

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications. 

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

题目大意:给一组各种物种的树,然后输出每种树的占总数的比例。

字典树吧。

这题有点坑,如果你按大小写26个字母加空格来处理的话,那你就RE到死吧,其实它给的数据不光是字母和空格,是所有字符。
也就是你的字典树是个126-32+1=95叉树,为了编写方便就是0~126(127叉树)

出现次数由节点上的变量cnt维护。

按字典序输出各字符的:采用树的中序遍历+回溯。

不难又不错的题,下面是字典树版:

Memory: 3092K  Time: 782MS

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

const int maxn=127;		//127叉树

typedef struct Node{
	int cnt;
	struct Node *ch[maxn];
}node;

node *T;
int tot;

void insert(char s[]){
	int i,j,len=strlen(s);
	node *u;
	u=T;
	for(i=0;i<len;i++){
		int id=s[i];
		if(u->ch[id]==0){
			node *t=(node*)malloc(sizeof(node));
			for(j=0;j<maxn;j++) t->ch[j]=0;
			t->cnt=0;
			u->ch[id]=t;
		}
		u=u->ch[id];
	}
	u->cnt++;
}

char name[40];
	
void ask(node* T,int cur){
	if(T==0) return ;
	int i;
	double res;
	if(T->cnt) {
		name[cur]='\0';
		res=(double)T->cnt/tot*100;
		printf("%s %.4f\n",name,res);
	}
	for(i=0;i<maxn;i++)
		if(T->ch[i]!=0){
			name[cur]=i;
			ask(T->ch[i],cur+1);
		}
	return ;
}

int main()
{
	int i,res,len;
	char str[40];
	T=(node*)malloc(sizeof(node));
	for(i=0;i<maxn;i++) T->ch[i]=0;
	T->cnt=0;
	tot=0;
	while(gets(str)){
		if(str[0]=='\0') break;
		insert(str);
		tot++;
	}
	ask(T,0);
	return 0;
}

这题map也能过:

Memory: 916K Time: 8735MS

#include <iostream>
#include <cstdio>
#include <iterator>
#include <map>
#include <string>
using namespace std;

int main()
{
	string str;
	int tot=0;
	map<string,int> mp;
	while(getline(cin,str)){
		mp[str]++;
		tot++;
	}
	map<string,int>::iterator it;
	for(it=mp.begin();it!=mp.end();it++){
		cout<<it->first;
		printf(" %.4f\n",(double)it->second/tot*100);
	}
	return 0;
}

快排也能过。。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值