Poj 2442 Sequence

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 7685 Accepted: 2538

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

题意:

给你n*m的矩阵,然后每行取一个元素,组成一个包含n个元素的序列,一共有n^m种序列,

让你求出序列和最小的前n个序列的序列和。


直接优先队列就Ok了;


#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;

int main(){
    int T;
    int n,m;
    int a[2020],d;
    priority_queue< int , vector<int> , greater<int> >que1;
    priority_queue< int , vector<int> , less<int> >que2;
    scanf("%d",&T);
    while(T--){
        while(!que1.empty())
            que1.pop();
        while(!que2.empty())
            que2.pop();
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++){
            scanf("%d",&d);
            que1.push(d);
        }
        for(int i=1;i<n;i++){
            for(int j=0;j<m;j++){
                scanf("%d",&a[j]);
            }
            while(!que1.empty()){
                int ans=que1.top();
                que1.pop();
                for(int j=0;j<m;j++){
                    if(que2.size()==m&&que2.top()>ans+a[j]){
                        que2.pop();
                        que2.push(ans+a[j]);
                    }
                    else if(que2.size()<m){
                        que2.push(ans+a[j]);
                    }
                }
            }
            while(!que2.empty()){
                que1.push(que2.top());
                que2.pop();
            }
        }
        cout<<que1.top();
        que1.pop();
        for(int i=1;i<m;i++){
            cout<<' '<<que1.top();
            que1.pop();
        }
        cout<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值