hdu4296 Buildings 贪心

Description

  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building. 
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building. 
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way. 
  Each floor has its own weight w  i and strength s  i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw  j)-s  i, where (Σw  j) stands for sum of weight of all floors above. 
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors. 
  Now, it’s up to you to calculate this value. 
 

Input

  There’re several test cases. 
  In each test case, in the first line is a single integer N (1 <= N <= 10  5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w  i and s  i (0 <= w  i, s  i <= 100000) separated by single spaces. 
  Please process until EOF (End Of File). 
 

Output

  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building. 
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0. 
 

Sample Input

       
       
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output

       
       
1 0 2
 
真的是一道贪心水题,但是读题读了好长时间。这道题目的意思是告诉你一栋楼把所有的地板放在一块每层地板都有自己的wi和si就是重量和承受的力量。每层都有PDV就是它上面的所有地板的重量和减去本层地板的承受的重量其实就是算上本层地板的所有重量减去本层的重量加上承受能力这样的话w+s越大的放在下面真个楼的PDV的最大值最小,让你求这个最小值,如果最小值小于0那么输出〇。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
    __int64 w,si,s;
}q[100010];
int cmp(struct node a,struct node b)
{
    return a.s<b.s;
}
int main()
{
   int n;
   while(~scanf("%I64d",&n))
   {
       for(int i=0;i<n;i++)
       {
           scanf("%I64d %I64d",&q[i].w,&q[i].si);
           q[i].s=q[i].w+q[i].si;
       }
       sort(q,q+n,cmp);
       __int64 sum=0;
       sum=q[0].w;
       __int64 ans=0;
       for(int i=1;i<n;i++)
       {
           sum+=q[i].w;
           ans=sum-q[n-1].s;
       }
       if(ans>0)
        printf("%I64d\n",ans);
       else
        printf("0\n");
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值