Buildings(贪心)

Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.

Input

There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).

Output

For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.

Sample Input

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3

Sample Output

1
0
2

就是n个楼层,有两个参数,重量w,和承受力s,然后有PDV,是该层上面的层的总质量-该层的承受力,然后求最大PDV的最小值。(如果PDV是负数结果就是0)
思路参照:https://blog.csdn.net/weixin_44049850/article/details/86552706

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <string>
#include <math.h>
#include <queue>
#include <set>
#include <stack>
#include <vector>

#define INF 0x3f3f3f3f
const int MAX = 0x3f3f3f3f;

using namespace std;
typedef long long ll;

struct node
{
    ll w;
    ll s;
}a[100005];

ll value[100005];

bool cmp(node n1,node n2)//从小到大排序
{
    return n1.s+n1.w<n2.s+n2.w;
}
int main()
{
    ll N;
    while(~scanf("%lld",&N))
    {
        for(ll i=0;i<N;i++)
        {
            scanf("%lld%lld",&a[i].w,&a[i].s);
        }
        sort(a,a+N,cmp);
        ll sum=0;
        ll max_=-INF;
        for(ll i=0;i<N;i++)
        {
            value[i]=sum-a[i].s;
            sum+=a[i].w;
            if(max_<value[i])
                max_=value[i];
        }
        if(max_<=0)
            printf("0\n");
        else
            printf("%lld\n",max_);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值