poj 2151 Check the difficulty of problems 概率dp

题意:在acm比赛中,n题,t队。给出每个队做对每题的概率,问每队至少对一题,至少有一队做对至少m题的概率

分析:dp,f[i][j]表示第i个队伍做对第j题的概率。g[i][j][k]表示第i个队伍对于前j题而言做对k道的概率。

g[i][j][k] = g[i][j - 1][k - 1] * (f[i][j]) + g[i][j - 1][k] * (1 - f[i][j]);

有了所有的g,我们就可以求出每个队至少做对1题的概率:ans *= 1 - g[i][n][0];

再减去每个队都只做对1~m-1题的概率(把每个队做对1~m-1题的概率加和,并把各队结果相乘)




Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5375 Accepted: 2371

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
double f[1001][31];
double g[1001][31][31];
int main()
{
    int n,t,m;
    while(~scanf("%d %d %d",&n,&t,&m))
    {
        if(n+t+m==0)
            break;
        for(int i=1; i<=t; i++)
            for(int j=1; j<=n; j++)
                scanf("%lf",&f[i][j]);
        memset(g,0,sizeof(g));
        for(int i=1; i<=t; i++)
        {
            g[i][0][0]=1;
            for(int j=1; j<=n; j++)
            {
                g[i][j][0]=g[i][j-1][0]*(1-f[i][j]);
                for(int k=1; k<=j; k++)
                {
                    g[i][j][k] = g[i][j -1][k -1] * (f[i][j])+ g[i][j -1][k] * (1- f[i][j]);
                }
            }
        }
        double ans=1;
        for(int i=1; i<=t; i++)
            ans*=1-g[i][n][0];
        //ans=1-ans;
        double ans2=1;
        for(int i=1; i<=t; i++)
        {
            double ans1=0;
            for(int j=1; j<m; j++)
                ans1+=g[i][n][j];
            ans2*=ans1;
        }
        ans-=ans2;
        printf("%.3f\n",ans);
    }
    return 0;
}

不算太难的一道题目,但是错了好几遍原因是poj的%lf要换成%f真心给跪了、。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值