C - Catch That Cow POJ - 3278(广搜)

C - Catch That Cow

POJ - 3278


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

emmm.....这题也是简单,就是自己的问题想歪了

然后还有几个runtime和wa的点.....

runtime就是

endd.digit>=0 && endd.digit<maxn &&book[endd.digit] == 0
这边要记住的就是  
endd.digit>0 && endd.digit<maxn 这个要在前面不会runtime 可能以前好多这样子的情况也都没有注意
经常runtime 这次我能说我找了好久嘛起码找了半小时 不断的尝试到底是哪里有问题 后来发现是这个的问题
简直要吐血

wa的点的话 emmm题目要求是0-----100000X  这边之间,注意的是0也是要求到的
而自己蠢就蠢在
endd.digit>=0 && endd.digit<maxn   少了一个= 导致一直wa  
ok 这个是这题我出现的两个错误点

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
int n,k;
const int maxn=1e6+10; 
struct node
{
	int digit;
	int step;	
};
int book[maxn];
void BFS()
{
	queue<node>qu;
	node beginn;
	beginn.digit=n;
	beginn.step=0;
	qu.push(beginn);
	while(qu.empty()==0)
	{
		node tem=qu.front();
		if(tem.digit==k){
			printf("%d\n",tem.step);
			return ;
		}	
		book[tem.digit]=1;
		qu.pop();
		node endd;
		for(int i=0;i<=2;i++){
			if(i==0)endd.digit=tem.digit+1;
			else if(i==1)endd.digit=tem.digit-1;
			else if(i==2)endd.digit=tem.digit*2;
			if(endd.digit>=0 && endd.digit<maxn &&book[endd.digit] == 0){
				endd.step=tem.step+1;
				qu.push(endd);
			}
		} 
	}
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		memset(book,0,sizeof(book));
		BFS();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值