uva 116 Unidirectional TSP 单向TSP 问题,经典dP(路径输出注意规划方向)

26 篇文章 0 订阅
该博客介绍了如何解决单向旅行商问题,即在只能从左到右移动的矩阵中寻找最小路径。问题描述了矩阵的结构和合法步骤,并提供了输入输出样例。解决方案将找到具有最小权重的路径,输出路径及其成本。
摘要由CSDN通过智能技术生成

Unidirectional TSP
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA 116
Appoint description:

Description
Download as PDF

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) – finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time – is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path’s weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

/*
Author:ZCC;
Solve:dp[i][j]:表示到(i,j)点最小值
类似数塔
状态方程是dp[i][j]=min{dp[i][j-1],dp[i+1][j-1],dp[i-1][j-1]}+a[i][j];
关键是路径的记录输出,这里我用的是pair<int,int>

*/
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<fstream>
#define pb(s) push_back(s)
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
using namespace std;
typedef vector<int> VI;
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define bug printf("===\n");
#define PL(x) push_back(x)
#define X first
#define Y second
#define vi vector<int>
#define rep(i,x,n) for(int i=x;i<n;i++)
#define rep_(i,x,n) for(int i=x;i<=n;i++)
const int maxn=1100;
const int inf=999999;
typedef long long LL;

LL a[200][maxn];
LL dp[200][maxn];
P p[200][maxn];//记录路径
int main(){
   // freopen("Text/in.txt","r",stdin);
    //freopen("Text/myout.txt","w",stdout);
    int n,m;
    while(~scanf("%d%d",&n,&m)){

        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%lld",&a[i][j]);
                p[i][j].X=p[i][j].Y=0;
            }
        }
        cl(dp,0);
        for(int j=m;j>=1;j--){//为了保障字典序最小,这里逆序枚举。
            for(int i=1;i<=n;i++){
                int x=i+1;
                int y=i-1;
                if(x==n+1)x=1;
                if(y==0)y=n;
                //dp[i][j]=min(dp[i][j-1],min(dp[x][j-1],dp[y][j-1]))+a[i][j];
                LL dp1=dp[i][j+1];
                LL dp2=dp[x][j+1];
                LL dp3=dp[y][j+1];
                if(dp1<=dp2&&dp1<=dp3){
                    dp[i][j]=dp1+a[i][j];
                    if(p[i][j].X==0||p[i][j].X>i)p[i][j]=P(i,j+1);

                }
                if(dp2<=dp1&&dp2<=dp3){
                    dp[i][j]=dp2+a[i][j];
                    if(p[i][j].X==0||p[i][j].X>x)p[i][j]=P(x,j+1);
                }
                if(dp3<=dp1&&dp3<=dp2){
                    dp[i][j]=dp3+a[i][j];
                    if(!p[i][j].X||p[i][j].X>y)p[i][j]=P(y,j+1);
                }
            }
        }

        LL mi=inf;P pos;
        for(int i=1;i<=n;i++)if(mi>dp[i][1]){
            mi=dp[i][1];pos.X=i;
            pos.Y=1;
        }

        for(int i=1;i<m;i++){
            printf("%d ",pos.X);
            pos=p[pos.X][pos.Y];
        }
        printf("%d\n%lld\n",pos.X,mi);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值