【HDU35350】【Bomb】

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 10630    Accepted Submission(s): 3753


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong




#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int T;
__int64 n;
char s[65];
__int64 dp[70][10];
__int64 f(int len,int n)
{
	//if(n == 0 && len == 1) return 0;
	if(len == 1) return dp[1][n] = 1;
	if(dp[len][n] > 0) return dp[len][n];
	dp[len][n] = 0;
	for(int i=0;i<=9;i++)
	{
		if(!(n==4 && i ==9))
			dp[len][n] += f(len-1,i);
	}
	return dp[len][n];
}
__int64 solve(__int64 x)
{
	__int64 ret = 0;
	sprintf(s,"%I64d",x);
	int len = strlen(s);
	int curlen = len;
	for(int i=0;i<len;i++)
	{
		int d = s[i] - '0';
		int j;
		for(int j=0;j<d;j++)
		{
			if(i >= 1 && (s[i-1] == '4') && j == 9) continue;
			ret += f(curlen,j);
		}
		curlen --;
		if(i >= 1 && s[i-1] == '4' && s[i] == '9') break;
	}
	return ret;
}
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%I64d",&n);
		memset(dp,-1,sizeof(dp));
		cout << n - (solve(n+1) -1 )<< endl;	
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值